Quick thought too about which to use due to readability:
var you = from factor in seansAwesomeness select new FactorLite { Amount = amount; };
or you could do:
Func<Person, FactorLite> selectFactorLite = currentFactor => new FactorLite { Amount = currentFactor.Amount }; seansAwesomeness.Select(selectFactorLite);
I guess it’s a matter of preference, but the first seems way too verbose for something too simple.